Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme

TEMA: Posible solucion a configuracion multi-gpu

Posible solucion a configuracion multi-gpu 5 meses 4 días antes #1

  • Bisagras
  • Avatar de Bisagras
  • Fuera de línea
  • Aficionado al motor
  • Mensajes: 32
  • Gracias recibidas 4
  • Karma: 0
Buenas, lo prmero indicar que el hecho de que en mi caso funcione, la solucion puede no funcionar en todos los casos, por lo que debeis jugar con las opciones.

Indicar tambien que en el caso de multi-gpu de AMD (Crossfire), podeis probar tambien, pero ojo, solo los ajustes del juego y el archivo video.ini, nvinspector es un software para grafics Nvidia.

Ayer, mientras estaba con trokolo configurando el juego comprobamos que los fps estaban en 48, algo insuficiente, y depues de ajustar las opciones no conseguimos mas de 50 y trokolo me comento que assetto se pega con las configuraciones multi-gpu, en mi caso un SLI de GTX-660ti.

Hoy me levante y se me encendio la bombilla. Recorde que en Arma 3, hasta que Bohemia lo arreglo, tuve problemas tambien con la configuracion multi-gpu y la solucion para ganar fps paso por, en lugar de bajar opciones, subirlas, y ajustar el perfil nvidia con un programa llamado nvinspector.

Asi las cosas, me puse a bucear y probar cosas, y encontre varias posibildades que me funcionaron, por lo que subi opciones y deje la configuracion tal que asi (os dejo subrayadas las que parece que son las culpables de que se desactive el SLI, por lo que es recomendable dejarlas asi):

- Resolucion 1920x1080, bajarla no sirvio de nada, asi que la nativa.
- Pantalla completa activado.
- Sincronizacion vertical desactivado (lo probare activo mas adelante).
- Frame limit off.
- Filtro anisotropico 16x.
- Anti Aliasing 4x.
- Detalles del mundo Maximo.
- Resolucion de sombras Ultra.
- Smoke generation very low.
- Show smoke in mirrors desactivado.
- Post processing effects desactivados (no me gustan, lo siento, probad el quemas os guste).
- Resolucion de espejos al maximo.
- High quality mirror refelction activo.
- Reflection quality al maximo.
- Reflection rendering frequency static (el valor mas bajo).

Como podeis ver, algunos valores los subraye, el motivo es que estos valores parece que son los culpables de que el sli se desactive.

A continuacion, abrid el archivo video.ini que hay dentro de la carpeta cfg EN LA CARPETA DE INSTALACION DEL JUEGO, no en la carpeta de mis documentos. Buscad el apartado cube map y dejadlo asi:

[CUBEMAP]
SIZE=512
FACES_PER_FRAME=6
FARPLANE=500

Hasta aqui lo referente a los ajustes del juego, que puede ayudar si teneis crossfire de AMD, pero si teneis AMD no sigais leyendo, pues ahora toca el nvinspector que es solo para usuarios de Nvidia.

Abrid el panel de control de Nvidia y en el apartado de configuracion de la aplicacion 3D buscad asseto corsa y cambiad el apartado de ahorro de energia a maximo rendimiento.

Descargaos nvinspector de la web de guru3d, abrid los perfiles de juegos y elegis assetto corsa, y buscad el apartado unknow o undefined, casi abajo, y dentro de el la linea siguiente:

0x00A0694B, pinchais en le valor pero no elijais otro del desplegable, modificad el valor seleccionado colocando el cursos en el principio de la linea, y cambiando 0x00000002 por 0x00000000, es decir, el ultimo borrad el 2 y pobned un 0, a continuacion le dais a la tecla tabulador y arriba del todo aplicais los cambios.

Listo, a mi con esto me paso de los 48/50 fps a unos magnificos 120.

No se como meter las capturas de los bench, asi que quedan pendientes.
Si ves el arbol con el que vas a dar.......es subviraje, si solo lo oyes.....eso es sobreviraje
Última Edición: 4 meses 1 semana antes por i T o X.
El administrador ha desactivado la escritura pública.

Posible solucion a configuracion multi-gpu 5 meses 3 días antes #2

  • JMCardenas
  • Avatar de JMCardenas
  • Fuera de línea
  • Socio SINL
  • Mensajes: 1230
  • Gracias recibidas 46
  • Karma: 7
Probaré a ver como se comporta mi Crossfire. En Assetto Corsa lo tengo que desactivar porque no me rula con el. Comentaré resultado


i7-2600K 3.4Ghz / 16Gb 4x4Gb GSkillRipjawsXDDR3 1600 / Asus ROG Strix Geforce GTX 1080 A8GB GDDR5X / 256Gb SSD Samsung840Pro SATA3 + 2x500Gb WDBlack SATA3 / Asus P8P67 Socket1155 / CoolerMaster 1000 80+Gold / ATX CoolerMasterCM690 II / NoctuaNH-D14 / Dell22" 1850x1050 2ms / G29 Logitech / Fibra 300-30 / Win7.64
El administrador ha desactivado la escritura pública.

Posible solucion a configuracion multi-gpu 5 meses 3 días antes #3

  • Bisagras
  • Avatar de Bisagras
  • Fuera de línea
  • Aficionado al motor
  • Mensajes: 32
  • Gracias recibidas 4
  • Karma: 0
Ok.
Cualquier duda lovemos por TS, recuerda que no debes hacerr el apartado de nvinspector.
Si ves el arbol con el que vas a dar.......es subviraje, si solo lo oyes.....eso es sobreviraje
El administrador ha desactivado la escritura pública.

Posible solucion a configuracion multi-gpu 5 meses 3 días antes #4

  • JMCardenas
  • Avatar de JMCardenas
  • Fuera de línea
  • Socio SINL
  • Mensajes: 1230
  • Gracias recibidas 46
  • Karma: 7
Pruebas terminadas. Y... por desgracia fracaso total. Con el Crossfire activado en cualquiera de sus configuraciones no paso de 5 FPS, y lo más sorprendente la CPU no baja del 150% :ohmy: :ohmy: :ohmy: :ohmy: No sabía que podía pasar eso. En las pruebas petó varias veces Asseto, me ponía la pantalla en rojo, y por si acaso en todas las demás salía escopetado. Siento decir que los consejos de Bisagras no me han funcionado.

He vuelto a bajar todo al mínimo, y llego a los 40 FPS cuando estoy solo, pero la CPU baja del 100% al 98%. Similar a lo que normalmente tengo, aunque algo más bajo que en otros circuitos, supongo que será por el mod de nada menos que 3 GB.

Seguiré intentando arreglar e investigar buscando solución. De momento mi participación en las competiciones de Assetto las dejo de momento en StandBay, aunque me veréis entrenar y probar buscando solución de vez en cuando.


i7-2600K 3.4Ghz / 16Gb 4x4Gb GSkillRipjawsXDDR3 1600 / Asus ROG Strix Geforce GTX 1080 A8GB GDDR5X / 256Gb SSD Samsung840Pro SATA3 + 2x500Gb WDBlack SATA3 / Asus P8P67 Socket1155 / CoolerMaster 1000 80+Gold / ATX CoolerMasterCM690 II / NoctuaNH-D14 / Dell22" 1850x1050 2ms / G29 Logitech / Fibra 300-30 / Win7.64
El administrador ha desactivado la escritura pública.

Posible solucion a configuracion multi-gpu 5 meses 3 días antes #5

  • i T o X
  • Avatar de i T o X
  • Fuera de línea
  • Administrador
  • Mensajes: 1482
  • Gracias recibidas 92
  • Karma: 7
Recomendación y no es de ahora:

no usar crossfire pues los hacedores de juegos no suelen tener en cuenta este tema.
A veces sale más a renta vender esas 2 tarjetas y comprar 1 mejor sin crossfire.
El administrador ha desactivado la escritura pública.

Posible solucion a configuracion multi-gpu 5 meses 3 días antes #6

  • Bisagras
  • Avatar de Bisagras
  • Fuera de línea
  • Aficionado al motor
  • Mensajes: 32
  • Gracias recibidas 4
  • Karma: 0
JM, he leido usuarios que comentan que han solucionado el problema con crossfire desactivando la app que indica las vueltas que trae el juego en origen, y creando un perfil crossfire en la aplicacion de amd para el ejecutable acs.exe, y adjudicandole el perfil del battlefield bad company 2

Otra solucion, parecida pero mas drastica con las apps.
ENLACE
Pruebalo y nos cuentas.
Si ves el arbol con el que vas a dar.......es subviraje, si solo lo oyes.....eso es sobreviraje
Última Edición: 5 meses 3 días antes por Bisagras.
El administrador ha desactivado la escritura pública.

Posible solucion a configuracion multi-gpu 5 meses 2 días antes #7

  • JMCardenas
  • Avatar de JMCardenas
  • Fuera de línea
  • Socio SINL
  • Mensajes: 1230
  • Gracias recibidas 46
  • Karma: 7
No llevo mas que las APP obligatorias. Funden el ordenador.

La primera la probé hace tiempo sin exito. Pero me creé un perfil para asstto corsa que desactiva el crossfire y le da todas las prioridades al juego. Es como mejor me va. Como bien dice iToX y me recomendaron los de Kunos hace tiempo... no usar multi GPU, el juego no está optimizado gráficamente. Y lo que es peor es que me dijeron que no lo iban a evolucionar ni intentar solucionar. Aún así no pierdo la esperanza cada vez que sacan una actualización.Pero solo sacan chorradas corrigiendo fallos de coches.

Miro el otro tema. Ya os contaré.


i7-2600K 3.4Ghz / 16Gb 4x4Gb GSkillRipjawsXDDR3 1600 / Asus ROG Strix Geforce GTX 1080 A8GB GDDR5X / 256Gb SSD Samsung840Pro SATA3 + 2x500Gb WDBlack SATA3 / Asus P8P67 Socket1155 / CoolerMaster 1000 80+Gold / ATX CoolerMasterCM690 II / NoctuaNH-D14 / Dell22" 1850x1050 2ms / G29 Logitech / Fibra 300-30 / Win7.64
Última Edición: 5 meses 2 días antes por JMCardenas.
El administrador ha desactivado la escritura pública.

Posible solucion a configuracion multi-gpu 5 meses 2 días antes #8

  • JMCardenas
  • Avatar de JMCardenas
  • Fuera de línea
  • Socio SINL
  • Mensajes: 1230
  • Gracias recibidas 46
  • Karma: 7
Es lo mismo. Mismo problema y no funciona a nadie que lo ha leído. De provecho solo que se desactive el Crossfire, que se desinstalen todas las App, incluso las básicas de Assetto. El que quiera verlas que monte otro ordenador al lado. . Algo que yo ya hago hace tiempo (lo de otro ordenador ni de coña) solo mantengo las APP que la organización obliga. yo corro sin datos a la vista. Y de los que tengo instalados poco me aportan de información en carrera, o es dificil de interpretar. Corro a oido... jajajajajaja mientras ruedo solo ni tan mal. Es curioso que a muchos les funcione decentemente y a unos cuantos ni de coña hagas lo que hagas. lo malo es el nulo caso que hacen a los que tienen problemas. Se despachan diciendo que no es problema suyo, que hay gente a la que les funciona bien, y ya tá.

Llegará algún día la solución. Espero saquen un Assetto Corsa 2, y que lo optimicen mejor gráficamente.


i7-2600K 3.4Ghz / 16Gb 4x4Gb GSkillRipjawsXDDR3 1600 / Asus ROG Strix Geforce GTX 1080 A8GB GDDR5X / 256Gb SSD Samsung840Pro SATA3 + 2x500Gb WDBlack SATA3 / Asus P8P67 Socket1155 / CoolerMaster 1000 80+Gold / ATX CoolerMasterCM690 II / NoctuaNH-D14 / Dell22" 1850x1050 2ms / G29 Logitech / Fibra 300-30 / Win7.64
Última Edición: 5 meses 2 días antes por JMCardenas.
El administrador ha desactivado la escritura pública.
Tiempo de carga de la página: 0.114 segundos
Gracias a Foro Kunena